Marketing Website Unaccessible
Incident Report for SpringAhead
Resolved
Thank you for your patience; there are no longer issues with springahead.com.
Posted Oct 25, 2019 - 10:46 PDT
Monitoring
A fix has been implemented and the site has returned. We will continue to monitor and ensure continuity of the fix. Thank you for your patience.
Posted Oct 25, 2019 - 09:59 PDT
Identified
The cause of the issue has been identified and a fix is being implemented.
Posted Oct 25, 2019 - 09:54 PDT
Investigating
At this time, springahead.com cannot be reached. Customers may access the SpringAhead product via my.springahead.com. There are no issues with the SpringAhead product at this time.
Posted Oct 25, 2019 - 09:50 PDT
This incident affected: SpringAhead Web App.