SSL Certificates
Incident Report for SpringAhead
Resolved
This incident has been resolved.
Posted Oct 04, 2021 - 09:31 PDT
Monitoring
A subset of our users are reporting warnings from their web browsers that communications to and from my.springahead.com, are unsecured.
Spring Ahead SSL Certificates are up to date. It is quite likely that browsers are caching an old certificate and not requesting a new one.

See this link for steps to help resolve this: https://support.zendesk.com/hc/en-us/articles/360000099508-Why-do-I-sometimes-get-incorrect-SSL-certificate-details-for-my-subdomain-
Posted Sep 30, 2021 - 17:15 PDT
This incident affected: SpringAhead Web App.