Happy Thanksgiving! SpringAhead offices will reopen on December 2, 2019
Incident Report for SpringAhead
Resolved
The SpringAhead team has resumed normal business hours as of this morning.
Posted Dec 02, 2019 - 11:54 PST
Monitoring
Due to the US Thanksgiving holiday, SpringAhead offices are closed to normal business on Thursday, November 28 and Friday, November 29. Customer support, billing and sales departments will resume normal business hours on December 2, 2019. Have a wonderful holiday!
Posted Nov 27, 2019 - 11:53 PST
This incident affected: Help Center.